Browser Support

Aleph.js requires a modern browser to support native ES module imports and dynamic imports during development:

  • Chrome >= 61
  • Edge >= 16
  • Firefox >= 60
  • Safari >= 11
  • Opera >= 48

nomodule.js Polyfill

(WIP, planning to implement in v0.3)
To support older browsers like IE11 in production, Aleph.js will create a polyfilled nomodule.js that use system.js to import modules.